The Multivista Documentation Software runs as a web application, meaning that everything is accessed through your web browser. In general, the more up to date your browser is, the better the application will run. We do our best to support older versions of the popular browsers but some features are simply not possible without the use of new generation HTML5/CSS3 compatible browsers.

  • Microsoft Internet Explorer: 8*,9,10
  • Microsoft Edge
  • Mozilla Firefox: All Versions
  • Google Chrome: All Versions
  • Apple Safari: All Versions

*Annotation tool is not supported
Our webcam timelapse viewer requires Adobe Flash (latest version recomended) in order to operate. Finally, our web application relies on cookies in order to ensure that only authorized users are able to see the content that this appropriate for their credentials. This means that you must have cookies enabled in your web browser.

Did this answer your question?